Login - Currently experiencing issue with 2-factor authentication
Incident Report for Simployer
Resolved
This issue has been resolved.
SMS text should be sent from our system now.

We apologize for the inconvenience.
Posted Jun 29, 2020 - 08:52 CEST
Investigating
An issue regarding the 2-factor authentication has been reported.
We are investigating the issue.
Posted Jun 29, 2020 - 08:33 CEST
This incident affected: Log on.