Phone Support Channel Unavailable

Incident Report for Simployer

Resolved

This incident has been resolved.
Posted Sep 15, 2026 - 10:25 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 15, 2026 - 10:24 CEST

Investigating

We are currently experiencing issues with our phone support channel, and calls may not connect. Our team is actively investigating the root cause.

In the meantime, please reach out to our support team via chat, which is fully operational. We apologize for the inconvenience and will post updates here as soon as we know more.
Posted Sep 15, 2026 - 09:11 CEST
This incident affected: Simployer Classic (HRM Web application) and Simployer One (Web app).