Issues in the main portal

Incident Report for Simployer

Resolved

This incident has been resolved.
Posted Jun 04, 2025 - 14:41 CEST

Investigating

Some users are currently experiencing issues on the main portal in Simployer Classic. We are investigating the situation at the moment.
Posted Jun 04, 2025 - 14:28 CEST
This incident affected: Simployer HRM (HRM Web application).