Talent Portal is down

Incident Report for Simployer

Resolved

This incident has been resolved.
Posted Mar 13, 2023 - 15:27 CET

Update

We are continuing to investigate this issue.
Posted Mar 13, 2023 - 15:26 CET

Investigating

We are looking into this and will update info as soon as we know more.
Posted Mar 13, 2023 - 15:20 CET
This incident affected: Simployer Talent Portal (Web Application).