We will be undergoing scheduled maintenance during this time.
Posted Dec 11, 2025 - 11:49 CET
Scheduled
We’re doing scheduled maintenance on Employee Surveys, and the service will be temporarily unavailable during this time: 9 January 2026 at 20:00 – 11 January 2026 at 23:59
During the maintenance window you: - Won’t be able to access the system, view results, or send out new surveys. - Won’t be able to respond to pulse surveys. - The mobile apps will also be unavailable during this time period.
We’ll have everything up and running again as soon as the work is completed. Thanks for your patience while we make things better behind the scenes! Let us know if you have any questions and please inform your organization about this if needed.
Warm regards, The Simployer Product Team
Posted Jan 09, 2026 - 20:00 CET
This scheduled maintenance affects: Simployer Employee Surveys (Engagement) (Web & app service, Public API, Push notifications, Email delivery).