Capitech Tid and Master - problem logging in for some customers
Incident Report for Simployer
Resolved
This incident has been resolved.
Posted May 07, 2021 - 13:20 CEST
Monitoring
Our hosting-partner have identified and corrected a problem.
We will monitoring this issue a bit further.
Posted May 07, 2021 - 12:05 CEST
Investigating
Some customers are experiencing problem logging on to applications Tid and Master.
Posted May 07, 2021 - 10:06 CEST
This incident affected: Simployer Time and Planning (Capitech Tid).