Can't access the 'Contracts' module

Incident Report for Simployer

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 00:08 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 11, 2025 - 12:11 CEST

Investigating

Some customers are reporting that they can't access the 'Contracts' module. We're working on resolving the issue.
Posted Jun 11, 2025 - 11:55 CEST