My Support is currently unavailable
Incident Report for Simployer
Resolved
The incident has been resolved, and My Support is now available again.
Posted Apr 02, 2024 - 12:33 CEST
Investigating
My Support, the support system for case registration at the Support Center, encompassing both technical assistance for HRM and our Expert Services, is currently unavailable. We are actively working to address and resolve the issues.
Posted Apr 02, 2024 - 10:59 CEST
This incident affected: Homepage (Norway/Sweden) (Supportcenter).