We are currently investigating issues affecting login, system performance, and the impersonation feature. Users may experience slow response times, problems signing in, or be unable to use impersonation. We will share updates as soon as we know more.

Incident Report for Simployer

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 17, 2026 - 12:44 CEST

Investigating

We are currently investigating this issue.
Posted Jun 17, 2026 - 11:27 CEST
This incident affects: Simployer One (Web app) and Simployer One Logon.