Issues loading pages

Incident Report for Simployer

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 17:24 CET

Investigating

We are investigating a problem that is causing abnormal behaviours in the app.

We apologise for any inconvenience caused, please stand by for further updates as we work on a solution.
Posted Feb 18, 2026 - 13:58 CET
This incident affected: Simployer One Logon.