Issues with Travel & Expenses

Incident Report for Simployer

Resolved

The system has been rolled back and is now in a stable state again.
Posted Oct 31, 2025 - 12:34 CET

Investigating

Several customers are reporting problems with the Travel & Expense module. We are currently investigating the issue.
Posted Oct 31, 2025 - 12:26 CET