Simployer Travel - currently unavailable
Incident Report for Simployer
Resolved
This incident has been resolved.
Posted Sep 28, 2022 - 12:25 CEST
Monitoring
Simployer Travel is back online. We continue to monitor the situation
Posted Sep 28, 2022 - 11:17 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 28, 2022 - 10:56 CEST
Investigating
We are currently investigating this issue.
Posted Sep 28, 2022 - 10:51 CEST
This incident affected: Simployer (Norway) (Simployer Web).